About

Member has chosen to not make this information public.

Groups (1)

Pages

Member not yet following any Pages.

Posts (6)

Nov 23, 2012 · blood in urine with no cause in Kidney & Bladder

Thanks for the reply. Last night I had a severe kidney episode which ended in passing a stone and while in the ER they discovered I had a urinary tract infection. I will be on antibiotics for 10 days and if the blood is still present my next step is to see a gyn doctor. The urologists I have seen don’t seem to be concerned but they don’t look any farther than the CT, MRI and cystoscope along with all the urine samples that all come up negative. I want to know what is going on, it drives me insane to see blood everytime I pee. Again, thanks for answering.

Oct 12, 2012 · blood in urine with no cause in Kidney & Bladder

I am female and have had Cat scans of both kidney and bladder, 9 urine tests, MRI, ultra sound of kidney and bladder and an invasive bladder test. All negative. No kidney stones, etc. I did find where Lipitor could cause bleeding after prolonged use and I am testing that out. No stress, pretty easy life. thanks for replying. No pain, have had since May. Also havehad numerous blood tests, etc and they are all normal.

Oct 10, 2012 · blood in urine with no cause in Kidney & Bladder

No monster drinks or coumadin. I did read that Lipitor will sometimes cause blood in urine so went off that a couple of weeks ago. Thanks

Oct 10, 2012 · blood in urine with no cause in Kidney & Bladder

Wouldn’t the colonoscopy have shown that? No doctor seems to be concerned but it is driving me nuts. I have seen three specialists and they all tell me this happens sometimes. Will be having another CAT scan in 6 months. thanks

Oct 10, 2012 · blood in urine with no cause in Kidney & Bladder

Also had a colonoscopy and that was okay too. I still wonder about medications I take. Lipitor and supplements could be a possibility. Thanks for replying.

Oct 8, 2012 · blood in urine with no cause in Kidney & Bladder

Have blood in urine. Had all tests of bladder and kidneys with no cancer cells anywhere. No pain, no other symtoms. Anyone have any information as to what may cause this.